Casting New Charts


First, you need to launch AstroApp.
  1. Go to http://astroapp.com and log in.
  2. Click the 'Launch AstroApp' button (it can be found on the Home page at the right side).
  3. AstroApp will appear in a new window. Depending on your browser configuration, you may be prompted for your username and password in that window.


To open the 'New Chart' window select Charts/New from the menu.
All new charts and all modifications done to existing charts will be saved automatically.

Creating a new chart

  1. Select the first chart by either clicking on the list of the Recent Charts or by selecting
    the corresponding tab in the main pane.
  2. Open a chart or create a new chart.

Editing a chart / Working with the Chart form

You can invoke the Edit Chart window from the File/Edit menu and from File/Open dialog box.
  1. Make sure the chart you want to edit is currently selected in the File/Open table or in the main pane tab.
  2. Select the File/Edit menu option. The Chart Edit window will be opened.
  3. Enter the following information (you can always use the Tab key to move forward to the next field):
    1. Name. This is a required field.
    2. Date. This is a required field. Please note that the date format can be changed from the Settings/Settings menu option (from the Localization tab).
    3. Time. This is a required field. Time format can also be changed from the Settings/Settings menu.
    4. Country. This is a required field. Please make sure to select the country prior to looking for the City.
    5. Location information: latitude, longitude, and time zone. All these fields are required. You can enter that information manually or search for the location.
      • There are two ways to search for the location:
        1. You can enter the City name (full or partial) and click on the "..." button next to the City text box. Note: city name must be entered without state, province or any other additional information.
        2. Alternatively, you can use the Map tab and search for the location using the World Map.
          1. In the Map tab, start typing the address or place name. The auto-complete dropdown with matching places will appear.
          2. Use your keyboard arrow keys to scroll this list up and down.
          3. Use the Enter key to select the required place/location. Note: some browsers will also allow you to use your mouse for selecting locations from the list.
          4. Once the place is selected, the red marker and details window will appear on the Map. Click on the red marker to select this location and to populate coordinates and time zone details.
      • There are also three ways to specify the time zone information:
        1. You can rely on the system to provide the Time Zone based on your location.
        2. You can search for any available time zone by entering the Time Zone name and clicking the "..." button next to the Time Zone field. This will open a new dialog box with the list of time zones that match your search criteria.
        3. Alternatively, you can specify your own time offset in the following format: +/- hh:mm:ss (seconds are optional). Some examples of the valid values are:
          1. +01:00 - this entry will also add 1 hour to the birth time.
          2. -00:30:00 - this will subtract 30 minutes from the birth time.
          3. -0:45:20 - this entry will subtract 45 minutes and 20 seconds from the original birth time.
                                                Note: entering a custom value for the time zone would mean that this value will always be used in all the derived charts and any historical time zone changes
                                            such as DST will be ignored.
    1. Type. This field is optional. You can specify the Type for your chart by selecting from one of the following values:
      1. Natal
      2. Horary
      3. Election
      4. Dicumbiture
      5. Event
      6. Mundane
    2. Coordinate System (Geocentric, Heliocentric, or Topocentric).
    3. House System.
    4. Zodiac. To calculate the chart in Western zodiac without Ayanamsa, select the Tropical Zodiac option. To calculate the chart in Sidereal zodiac, select one of the available Ayanamsa options.
    5. Height. This field is used to specify elevation above sea level in meters. When searching for locations using the Cities dialog box or the Atlas, this field will be populated automatically.
    6. Source. The values are based on the Rodden Ratings System. This is a classification system proposed by Lois Rodden.
    7. Tag and Description. These fields are optional. You can enter any text there.
  1. After filling out the form, click the Update button to update the currently selected chart or click the Add New button to cast a new chart. The new chart will be generated and presented in the main window.
    Clicking the Restore Default button will reset all the values in this form back to User Defaults. The date and time will be reset to your current date and time in your local time zone.



Creating derived charts

  1. Open or create the 2nd chart. You can also use derived charts such as Returns or Progressions.
  2. Expand the View menu and select the BiWheel menu option. The table with all the charts calculated during your current session will open.
  3. Select the second chart from the table. The BiWheel chart will be shown in the main pane.